Plugin Requirements

To use Delicious recipes on your website, we recommend the following:

  • WordPress version: 5.1.0 or Later
  • PHP version: 5.6 or Later

If you also want to use the Delicious Recipes Widgets and Blocks plugin, the following will be the plugin requirements:

  • PHP version: 7.4 or Later
  • Elementor plugin version: 3.6.6 or Later
New Theme Release: Check out beautiful and feature-rich recipe theme - Yummy Bites ProLearn More